Home » Blog » Exchange 2010 SP2 setup/upgrade failed because roles aren’t current: AdminToolsRole

Exchange 2010 SP2 setup/upgrade failed because roles aren’t current: AdminToolsRole

After fixing my previous error (setup/upgrade failed while performing action install) it looked like i was successfully upgrading my Exchange 2010 server to SP2, but unfortunaly i received the following error when updating the Mailbox Role.

Error:
This server role can’t be installed because the following roles aren’t current: AdminToolsRole

When i checked the registry i noticed a different ConfiguredVersion and UnpackVersion.

Solution:
I changed the ConfiguredVersion to be the same as the UnpackedVersion 14.2.247.5

After that i checked the \MailboxRole\ registerkey and noticed that the Action key was back, so to be sure i also deleted that and rebooted my machine.

Check Also

VMware Certified Professional – Recertification every 2 years

VMware has made some important changes to it’s certifications, this is probably affected most VCPs! …

One comment

  1. Thank you for your solutions! Your Blog was a great help!

Leave a Reply

Your email address will not be published. Required fields are marked *